QSC GX 7 used in my rig

Is this amp OK?
Post Reply
Message
Author
User avatar
heavybdrums
Posts: 347
Joined: Fri May 22, 2015 3:46 pm
Contact:

QSC GX 7 used in my rig

#1 Post by heavybdrums » Sun Sep 10, 2017 8:00 pm

Time has gone by and I have run quite a few live band shows very successfully using 4 X Titan 39's "V" plated powered with a QSC GX 7 through a Driverack PA 2 with appropriate limiter settings.
For tops I use the two DR 250's powered with a QSC GX 5.
All stage monitors, two WH 8's and two WH 10's powered with a pair of QSC GX 3's.
I use a mono pair of WH 8's for front fills set on top of the subs powered with another GX3.
Image
Using the above rig for live bands I would have to say it is THE best live sound rig of it's size anywhere in my area. Also with live bands I never hit the limiters or see the clip light on any amps light up, the rig runs effortlessly.
However more recently I have run into electronic musicians and modern pop music which includes a lot of 30 hz and so have just finished building a Tuba 60 27" wide with a lab 15 and love it for this kind of music. I plan on having two of these in the future. However, the GX7's clip light flashes frequently on the bass drops and for this type of material I feel that the GX 7 is being flogged even though the limiter is still set to a conservative 55 volts within the PA 2 (lab 15 can have 60v) and the high pass is set to 25 hz.
Doing the math 60 volts into 8 ohms is only 450 watts, which the GX 7 should do 725 watts stereo @ 8 ohms. I understand it takes a lot more watts to reproduce the frequent excursions into 30 hz this music includes.

SOOOO.. why is my amp working too hard with this type of music when it seems appropriate from the math and do I need another larger wattage amp for this purpose?
4x WH8 delta pro
2x WH10 Deltalite 2510
2x Dr250 Deltalite II 2510
4X Titan 39 3012lf, 28"
4X Tuba 60 W/ lab 15
FB: https://www.facebook.com/sunsoundservices/ likes appreciated

CoronaOperator
Posts: 1379
Joined: Wed Mar 25, 2009 7:07 pm
Location: Medicine Hat, Alberta, Canada

Re: QSC GX 7 used in my rig

#2 Post by CoronaOperator » Sun Sep 10, 2017 8:21 pm

heavybdrums wrote: SOOOO.. why is my amp working too hard with this type of music when it seems appropriate from the math and do I need another larger wattage amp for this purpose?
I don't know why the amp is showing clipping, have you measured the voltage coming out?

But for EDM you should have 4 of those T60's, one or even 2 isn't enough
Built:
17" width 10" driver Autotuba
2 x 29" width dual Lab12 Tuba60
6 x DR250 2510/asd1001
In progress:
2 x DR250 2510/asd1001
For best results, point the loud end of the array towards the audience

User avatar
Tom Smit
Posts: 6519
Joined: Sat Jan 05, 2008 1:24 pm
Location: Sarnia, Ont. Canada

Re: QSC GX 7 used in my rig

#3 Post by Tom Smit » Sun Sep 10, 2017 8:59 pm

Playing the lower notes will require twice the power for the same "apparent" volume as you noted.
What slope is your hi-pass set at?
TomS

User avatar
Bill Fitzmaurice
Site Admin
Posts: 26217
Joined: Tue May 02, 2006 5:59 pm

Re: QSC GX 7 used in my rig

#4 Post by Bill Fitzmaurice » Sun Sep 10, 2017 9:01 pm

The clip light shows that the signal going into it is too hot. Back off on the low end EQ.

CoronaOperator
Posts: 1379
Joined: Wed Mar 25, 2009 7:07 pm
Location: Medicine Hat, Alberta, Canada

Re: QSC GX 7 used in my rig

#5 Post by CoronaOperator » Sun Sep 10, 2017 9:05 pm

I would also measure the resistance of your speaker/cable using an ohmeter. A shorted cable/bad voice coil can trigger the clip lights too.
Built:
17" width 10" driver Autotuba
2 x 29" width dual Lab12 Tuba60
6 x DR250 2510/asd1001
In progress:
2 x DR250 2510/asd1001
For best results, point the loud end of the array towards the audience

User avatar
heavybdrums
Posts: 347
Joined: Fri May 22, 2015 3:46 pm
Contact:

Re: QSC GX 7 used in my rig

#6 Post by heavybdrums » Sun Sep 10, 2017 9:21 pm

The speaker cable is 20' 12 ga wire..so I don't think the cable is the problem.
I will try backing off the low end eq, but seems like it would defeat the purpose of a 25 hz sub for electronic music.

the crossover slope is a L/R 48db/oct set to 25 hz.
Thanks for the info, I will go into a more thorough look into the Driverack settings.
4x WH8 delta pro
2x WH10 Deltalite 2510
2x Dr250 Deltalite II 2510
4X Titan 39 3012lf, 28"
4X Tuba 60 W/ lab 15
FB: https://www.facebook.com/sunsoundservices/ likes appreciated

Grant Bunter
Posts: 5869
Joined: Mon Nov 28, 2011 11:12 am
Location: Ilfracombe Queensland Australia
Contact:

Re: QSC GX 7 used in my rig

#7 Post by Grant Bunter » Mon Sep 11, 2017 3:40 am

There's plenty of amps that will put out greater than the "stereo" or 2 channel figures if you only have a cab on one channel.
+1 on measuring the voltage output as you have the rig set up now to ensure this isn't happening...
Built:
DR 250: x 2 (melded array) with March 2012 plans.
T39's: 4 x 20" BP102 , 2 x 28" 3012lf.
WH8: x 3 with melded array.
Bunter's Audio and Lighting "like"s would be most appreciated...

User avatar
Bill Fitzmaurice
Site Admin
Posts: 26217
Joined: Tue May 02, 2006 5:59 pm

Re: QSC GX 7 used in my rig

#8 Post by Bill Fitzmaurice » Mon Sep 11, 2017 6:44 am

heavybdrums wrote: I will try backing off the low end eq, but seems like it would defeat the purpose of a 25 hz sub for electronic music.
Not when the signal is boosted in the lows on the source media.

Rich4349
Posts: 620
Joined: Wed Jul 30, 2008 10:18 am
Location: Kankakee, IL

Re: QSC GX 7 used in my rig

#9 Post by Rich4349 » Mon Sep 11, 2017 12:39 pm

I didn't realize that would make a difference. I would have assumed (yes, I know) that 50v etc was 50v, if a limiter was in place in the system.

https://i.ytimg.com/vi/GD6qtc2_AQA/maxresdefault.jpg
2 DR250s, 2 27" Lab15 T-60s, 2 30" Neo Titan 39s, 1 Autotuba...and looking for more!

User avatar
Bill Fitzmaurice
Site Admin
Posts: 26217
Joined: Tue May 02, 2006 5:59 pm

Re: QSC GX 7 used in my rig

#10 Post by Bill Fitzmaurice » Mon Sep 11, 2017 2:46 pm

Rich4349 wrote:I didn't realize that would make a difference. I would have assumed (yes, I know) that 50v etc was 50v, if a limiter was in place in the system.
It depends on how fast the limiter attack is. Transients can make their way past a limiter. Chances are it will clamp down on them before they can do any damage, and I wouldn't be too concerned about a clip indicator that periodically flickers. A clip light that stays lit is a different story.

User avatar
heavybdrums
Posts: 347
Joined: Fri May 22, 2015 3:46 pm
Contact:

Re: QSC GX 7 used in my rig

#11 Post by heavybdrums » Mon Sep 11, 2017 6:18 pm

Thanks for all the info guys, I have fixed the problem by going through all the PA 2's setup with a fresh start, turned off all eq (parm & graphic, even the auto eq) and now the clip light doesn't ever come on and the limiters attack before clip light just flashes momentarily @100% volume on this tune:
https://soundcloud.com/thatsvast/flashlights
4x WH8 delta pro
2x WH10 Deltalite 2510
2x Dr250 Deltalite II 2510
4X Titan 39 3012lf, 28"
4X Tuba 60 W/ lab 15
FB: https://www.facebook.com/sunsoundservices/ likes appreciated

Post Reply